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Chapter 0 -  About this document

This document is the user manual for the Utility Node of Concept Systems Limited’s integrated
navigation system designed for marine geophysical survey usage (SPECTRA).  SPECTRA is a modular
system comprising various Nodes.

This manual describes how to use the Utility Node.  Chapter 1 introduces the Node and explains how to
get started with it.  Subsequent chapters explain how to use the Calibration, Baseline Crossing and
Coordinate Conversion utilities.

For a general overview of the operation of SPECTRA and for a description of features and conventions
common to SPECTRA Nodes, see the SPECTRA User Manual - Beginners Guide.  For a glossary of
terms, see the SPECTRA User Manual - Glossary.  For brief descriptions of each Node, detailed
descriptions of the options provided by other SPECTRA Nodes, and details of how to start each Node,
see the Spectra Software Installation and Set Up manual.

Revision history

Document Reference Date Notes
SPCTRA_2.0/USER/UN/1.0 1st November 1996 First issue
SPCTRA_2.0/USER/UN/2.0 20th May 1997 Document format and other minor errors

corrected.
SPECTRA_8.x.x/USER/UN/3.0 March 2000 Calibration Utility updated.

Can get Projection data from Data Server.

Document cross-reference

Document Reference Title
SPECTRA/INSTALL Spectra Software Installation and Set Up
SPECTRA/USER/BEGIN SPECTRA User Manual - Beginner’s Guide
SPECTRA/USER/GLOSS SPECTRA User Manual - Glossary
SPECTRA/USER/DSN SPECTRA User Manual - Data Server Node
SPECTRA/USER/NCN SPECTRA User Manual - Network Calculation Node
SPECTRA/USER/RTCN SPECTRA User Manual - Real Time Configuration Node
SPECTRA/USER/LMN SPECTRA User Manual - Line Management Node
SPECTRA/USER/RN SPECTRA User Manual - Replay Node
SHARED/RUNT RTNµ Hardware Installation and Operation
SHARED/RTNU_OP RTNU & Closure Unit Hardware Installation and Operation

Conventions used in this document
The conventions used in this, and all other SPECTRA user manuals, are
those defined in the SPECTRA User Manual - Beginner’s Guide.



SPECTRA User Manual - Utility Node Introduction

SPECTRA_8.x.x/USER/UN/3.0 1-1

Chapter 1 -  Introduction

This chapter introduces the Utility Node and explains how to get started with it.

What is the Utility Node?
The SPECTRA Utility Node (UN) is used to run any of an extendible set
of utilities to perform particular computations using data available from
SPECTRA’s Data Server.

Utility Node operational flow
The following diagram shows the process of using the Utility Node, and
the relationship between this process and the Node’s main windows.

For Each Survey

While required data is available

Select Utility to run

Run Utility

UN window
Connect UN to

Data Server

UN window

Utility window

Getting started

Common features
Note that some feature are common to all SPECTRA Nodes.  These
include:

•  general use of the mouse buttons;

•  status areas on a Node’s main window;

•  opening and saving configuration files, and exiting from the Node
(via the File menu on a Node’s main window);
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•  submitting configuration changes to the Data Server (via the Submit
button or the File menu on a Node’s main window);

•  selecting or specifying a file (for opening or saving the
configuration);

•  connecting to and disconnecting from the Data Server, and viewing
communications errors (via the Communications menu);

•  applying any configuration changes to the Node and exiting from the
sub-window (via the OK, Apply and Cancel buttons or the File menu
on sub-windows of the Node); and

•  obtaining help.

Starting the Utility Node
This Node would normally be started via the Monitor Node.  Details of
the commands required to start this and other SPECTRA Nodes can be
found in the Spectra Software Installation and Set Up manual.

The main window
The starting point for using the Utility Node is the Utility Node window:

From here you can access the Calibration Utility, the baseline Crossing
Utility and the Coordinate Conversion Utility.  Select the required utility
from the Options menu.
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Chapter 2 -  The Calibration Utility

The Calibration Utility window
When you select Calibration from the Options menu on the Utility Node
window, the following is displayed:

Use the Calibration Utility window to set an interval and duration, and
control the logging of calibration data to file.  Current or logged
calibration data can be printed.

Note that data is periodically flushed to disk so that in the event of an
error, you will have a partially complete set of data.

Selecting an interface
Click the Add button to bring up the Calibration Utility Interface
Selection window:
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This lets you select the interfaces and channels from which to use data.

Select an interface on which the data for calibration is being received
from the Interfaces list box.  The channels for that interface appear in the
Channels list box where you can choose which channels to include.  For
example:

Click OK when you have finished making your selections.  If you want to
alter your choices, highlight the relevant interface in the Calilbration
window and click the Edit button to bring the Interface Selection window
back.

Specifying logging interval and duration
Specify the interval (in seconds) at which data from the selected
channels is to be logged for calibration purposes.  Enter this in the
Interval (seconds) field.  The default value is 1.

Specify the duration (in minutes) for which data is to be logged.  Enter
this in the Duration (minutes) field.  The default value is 1.

Changing the filename
If you wish, you can change the file name to which the data for
calibration is logged.  To do this, amend the default name displayed in
the Filename field.  The default file name is Calibration.000 for the
first logging of data in your Calibration Utility session,
Calibration.001 for the second, and so on.  The file is normally
created in the $PN_LOG directory (or if this does not exist, in the default
directory, which will usually be the current one).  It is impossible to
overwrite files, and specifying an existing file name will result in the
creation of a default name.

Starting logging
Start logging by selecting Logging|Start.  Once logging is underway, you
can pause it at any point (via Logging|Pause), continue logging after a
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pause (via Logging|Continue) or stop the logging before the end of the
specified duration (via Logging|Finish).  The data being logged is
displayed in the Data panel:

The logging status at any time is shown in the Status field, and can be:

Not logging;

Logging n of m;

Paused logging at n of m;

Continue logging; or

Finished logging at n of m

where n is the number of values for each channel so far logged, and m is
the expected total number of values to be logged if logging is allowed to
continue for the specified duration.  Note that the Finished values for n
and m may not be equal if you stop logging before the specified duration
has elapsed.

Note that the current time and the time at which the Calibration Utility
was started are displayed, for information.  This time is derived from
GPS data if this is available from the Data Server; if not, standard UNIX
time is used.  The chosen method is indicated in the Calibration Utility
window.
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Printing the calibration data
If you wish, you can send the currently logged calibration data to a
connected printer (via File|Print Current Data).

You can also print from a file (via File|Print Data File).  This option
shows a file selection window on which you can specify the required
path and file name:
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Chapter 3 -  The Baseline Crossing Utility

The Baseline Crossing window
When you select Baseline Crossing from the Options list on the Utility
Node window, the following is displayed:

From here you can choose live or replayed data that has been logged via
the Data Logging Node, or you can choose a Baseline Crossing logged
file if data has been saved from a previous Baseline Crossing session.
You can also define the stations and antenna used in the calculation, and
the type of baseline crossing required.  Finally, you can choose how to
display the data, and start and stop logging.

Selecting input type
Select the type of Input you require from the pulldown menu.  Choose
from Live or File.  If you select Live, the P2/91 File field becomes
unavailable.

Selecting a file
To select a File, bring up the appropriate file selection window either by
right clicking on the P2/91 File or the Data File field, or by using
File|Open P2/91 or File|Open.  Select and OK the file you require.

Note on files: If you select a data file, all the information needed to run the utility is
automatically made available.  No other part of SPECTRA is necessary
to run the utility.  With a P2/91 file, you will need at least the Line
Management Node.
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Selecting the antenna
Select the required Radio Navigation system antenna; right click on the
Antenna field to choose.  If only one antenna is defined, it will be
selected automatically.

Choosing the stations
Choose the stations required.  Right click on each Station field to show a
list of available stations.  For each field, choose the station you want
either by double clicking on the station name or by clicking once on the
name and then using File|Select.

Selecting baseline calculation type
Select the type of Baseline calculation required from the pulldown menu.
Choose from Range-Range Sum, Range-Range Difference and
Hyperbolic.

Controlling the logging
Control the logging of baseline crossing data.  From the Options|Logging
menu, choose Start or Finish logging as required.  Choose whether to
enable or disable the facility to estimate C-O for each new item range by
selecting the Fit Data Online option from the Options menu.  A small
square appears next to the option when it is enabled.
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Viewing the data as a graph
From the Base Line Crossing window, choose Display|Graph to display
the Baseline Crossing Graph window:

At the top of the graph, the name of the file from which you are reading
is displayed if you selected File as your input type, otherwise you are
told that the utility is reading Live Data, and the status is displayed: Not
Logging, Logging or Finished Logging.  The type of Baseline selected is
also displayed.

Within the curve of the graph, observations are green, fitted data is
yellow, and any observations that you have rejected (see Viewing the
data as a table) will appear in red.

Displaying information
You can choose whether or not to display information about the stations
and the GRS by using Options|Display Stations and Options|Display
GRS, respectively.  Select the station coordinate type, using
Options|Coordinate Display Type to choose between Geographical
(Latitude and Longitude) and Map (Northings and Eastings).

Observations, rejections, Baseline Length, SD and C-O are always
displayed.  Note that if using input from a file, the C-O data is
completed, whereas live input, if fitting on-line, gives readings that are
based on the data received so far, which will eventually become
complete.  (If not fitting on-line, this data will be unavailable until
completed.)
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Setting the graph scales
Set up the graph scales, choosing either default scales or defining the
scales yourself.  If you choose default values (using Options|Default
Scales), the maximum and minimum values will be set to the default
values for the individual data set.

If you wish to define the scales yourself, select Options|Define Scales or
right click on the graph to display the Baseline Crossing Scales window:

Changes to the scales made by typing in the number fields are only
effected when you apply them.

Changes made to the scales by using the buttons for shrinking or
stretching are effected immediately.  To return to default values, select
the Default button.

Zooming in on the graph
You can zoom in to show an area of the graph in more detail.  Left click
on one corner of the desired area and hold the button down, then drag the
mouse to the diagonally opposite corner and release the button.  The
graph will change to contain only the ranges within the box you have
created:
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The information displayed on the screen is the same as that on the
original graph.  The scales are calculated automatically, although you
can adjust them if you wish.

The individual observations appear in green, the fit line in yellow, and
any observations you have rejected (see Viewing the data as a table
below) will appear in red.

Printing the graph
To print the graph, select File|Print graph from the Baseline Crossing
Graph window; this sends the graph to an on-line printer.  The printout
will have the same scaling as that displayed on screen, and will also
show station information, GRS information and details of the fitting
algorithm.

Viewing the data as a table
From the Base Line Crossing window, select Display|Table (or
alternatively, centre click on the Baseline Crossing Graph window).
This will display the Baseline Crossing Observation Rejection window:

For live data, the table updates with every fresh observation, with the
newest data at the bottom of the display.  A Pause button is available if
required (this is greyed out for data from a file).  For data being read
from a file, the observations appear on screen from the start of the file.

The number of observations and rejections so far are shown at the top of
the screen.

Rejecting an observation
To reject an observation, click on the relevant line.  Rejected
observations are highlighted.  To undo a rejection, click on it again, or
select Options|Clear Selection to undo all rejections.
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Viewing status messages
The Status field shows the current status of the utility.  To see a listed
history of Status messages, select Options|Display Status Messages.
These are then shown in the Baseline Crossing Status Message window:

Select Clear to clear any messages.
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Chapter 4 -  The Coordinate Conversion
Utility

This utility allows you to convert points between satellite GRS and survey GRS, and between map and
geographical coordinates.  This utility is free-standing and therefore it can be run whilst unconnected to
the Data Server.

The Coord Convert window
From the Options menu on the Utility Node window select Coordinate
Conversion to reveal the Coord Convert window.

From here you can select how points will be entered: in geographical or
map coordinates, and choose to convert points from satellite to survey
GRS or vice versa.

Selecting format of coordinates
Select the format in which to enter coordinates by selecting either the
Geographical or Map button.  Depending on your choice, the
Latitude/Longitude fields or the Northing/Easting fields will be enabled.

Converting between satellite and survey GRS
Specify whether you will convert from satellite to survey GRS or vice
versa, by selecting the appropriate button.  Depending on your choice,
the Satellite Datum fields or the Survey Datum fields will be enabled.
Note that if you have opted to perform an ED50 transformation, the
Survey → Satellite button will be disabled.  This is because such
transformations are one-way processes.
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Converting coordinates
Enter the coordinates of the point you wish to convert by typing directly
into the appropriate field.

Convert the coordinates by selecting Apply.  You will now have three
new pieces of information relating to your original entry:

the coordinates of the point in the same system, different GRS;

the coordinates of the point in a different system, same GRS;

the coordinates of the point in a different system, different GRS.

When you are finished converting points leave the Coord Convert
window.

Selecting the satellite & survey datums & projection
From the Coord Convert window, select Options|Geodetic Reference
System to elicit the UN Geodetic Reference System editor:

From here you can open an existing GRS file but may not write to such
files: fields are editable but changes may not be saved.

WGS 84 is the default datum for both satellite and survey.

Viewing satellite and survey datums
Use File|Open to load a GRS data file.  This will provide definitions of
the satellite and survey datums.  Note that the satellite datum is always
WGS 84.
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If you wish, edit any of the fields by typing directly into the field.  Note
that these changes cannot be saved: GRS files may only be altered via
the LMN.  See the SPECTRA User Manual - Line Management Node for
details on editing these files.

Specifying the projection
Specify the projection to use in the conversion (this information is not
held in the GRS file).  Select Options|Projection to reveal the UN
Projection window:

Choose the projection from the pull-down menu at the top of the
window.  Fields are enabled and labelled depending on your selection.

Alternatively, choose Get Projection from Data Server from the Options
menu to synchronise the projection data with whatever you set up in the
LMN.  This option is only available when the Utility Node is connected
to the Data Server.  If you run the Utility Node with the -X command
line option then this synchronisation takes place at start up.

Entering projection parameters

UTM Projections

For UTM projections, select the required hemisphere (North or South)
using the pulldown menu and enter the zone number for the projection.

Other projections

For other projections, enter the latitude and longitude of the projection's
origin.  Alternatively, enter the Northing and Easting of the projection's
origin (in current length units).

Lambert projections

For Lambert (1 and 2) projections only, enter the first parallel, in
degrees.  For Lambert 2 projections only, also enter the second parallel,
in degrees.
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RSO projections

For RSO projections only, enter the initial bearing and the skew angle, in
degrees.

Scale factor

Enter the scale factor for the projection.

Viewing comments
The Comments field at the foot of the GRS Editor shows the first line of
any further information that may be relevant to the GRS set-up.  More
information may be shown by selecting Options|View Parameters to
display the following window:
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